Uh Oh! Gallery Extension Made Web Site Disappear?

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Uh Oh! Gallery Extension Made Web Site Disappear?

Postby Stark Raving » Sun Dec 13, 2009 1:56 am

Well, this is strange. I added the gallery tag to my gallery page (latest Px install) then clicked on save and the screen went blank. White as snow. I tried reloading the page, using the browser bookmark for the login (using latest Firefox) but still white. No source code shows. Nada.

What have I done?! Likely this isn't an extension problem, but that's what I was doing when it happened.

http://nirvanabyinstallments.com

I checked out the rest of the forum, tried clearing cache, but still a blank. Can't check the log either to see what may have happened.

I looked into my files on ftp and saw htaccess files that I didn't add in my template and internal template folders. Are they suppose to be there? They both are:

Code: Select all
<Files ~ ".(htaccess|htpasswd|inc|html|htm|php|tpl)$">
deny from all
</Files>


Well, I deleted them, but it didn't do anything. I think I need to send login details to someone. Who would like to tackle this?
"After I'm dead I would rather have people ask why I have no monument than why I have one." ~ Cato the Elder

"In heaven all the interesting people are missing." ~ Friedrich Nietzsche
User avatar
Stark Raving
Silver Sponsor
 
Posts: 108
Joined: Tue Dec 11, 2007 9:24 pm
Location: Vancouver Island

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby hansfn » Sun Dec 13, 2009 1:34 pm

This is actually documented - read Troubleshooting PivotX - If nothing works, and you can't get into the backend.

PS! The .htaccess files you deleted is part of PivotX.
hansfn
Developer
 
Posts: 3212
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby Stark Raving » Sun Dec 13, 2009 10:41 pm

Thanks, Hans. I managed to get into the backend and delete the gallery extension last night. All is right again. I even re-installed the gallery extension to see if it was in fact the problem. I got the white screen again when I placed the gallery tag in the page and hit the post button. Guess I'll have to think of something else for posting photos. C'est domage.

Cheers
"After I'm dead I would rather have people ask why I have no monument than why I have one." ~ Cato the Elder

"In heaven all the interesting people are missing." ~ Friedrich Nietzsche
User avatar
Stark Raving
Silver Sponsor
 
Posts: 108
Joined: Tue Dec 11, 2007 9:24 pm
Location: Vancouver Island

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby hansfn » Sun Dec 13, 2009 11:00 pm

Are you running PivotX 2.0.0 and downloading the latest gallery extension from SVN? If so, that won't work - they aren't in sync. You better grab a new version of PivotX from http://pivotx.net/files/unstable-development/ - it includes the gallery extension.
hansfn
Developer
 
Posts: 3212
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby Stark Raving » Mon Dec 14, 2009 12:10 am

Hans,

Ah. Yes, it's Px 2.0.0, etc. Will download the newer Px with synched gallery extension. Thank you.
"After I'm dead I would rather have people ask why I have no monument than why I have one." ~ Cato the Elder

"In heaven all the interesting people are missing." ~ Friedrich Nietzsche
User avatar
Stark Raving
Silver Sponsor
 
Posts: 108
Joined: Tue Dec 11, 2007 9:24 pm
Location: Vancouver Island

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby Stark Raving » Mon Dec 14, 2009 7:14 pm

Hans,

Updated to 2.1.0 alpha 3, added the gallery tag to my page and received the following:

Smarty error: [in db:tpl_adf32f44ce line 1]: syntax error: unclosed tag {gallery} (opened line 1). (Smarty_Compiler.class.php, line 317): 256
"After I'm dead I would rather have people ask why I have no monument than why I have one." ~ Cato the Elder

"In heaven all the interesting people are missing." ~ Friedrich Nietzsche
User avatar
Stark Raving
Silver Sponsor
 
Posts: 108
Joined: Tue Dec 11, 2007 9:24 pm
Location: Vancouver Island

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby Schop » Mon Dec 14, 2009 7:47 pm

There is probably a typo or something in your template code. Can you show us the template code you're using?
User avatar
Schop
Contributor
 
Posts: 484
Joined: Mon Apr 21, 2008 1:47 pm
Location: Hudson, Ohio

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby hansfn » Mon Dec 14, 2009 10:44 pm

That error message is very clear. You have inserted [[gallery]] without [[/gallery]] ... Please look at the start of the file extensions/gallery/hook_gallery.php - everything is documented there. An example:

Code: Select all
  <div class="gallery">
  [[gallery popup="thickbox"]]
    <a href='%imageurl%%filename%' class="thickbox" title="%title%" rel="gallery-%uid%" >
    <img src="%pivotxurl%includes/timthumb.php?src=%filename%&amp;w=106&amp;h=80&amp;zc=1" alt="%alttext%" />
    </a>
  [[/gallery]]
  </div>
hansfn
Developer
 
Posts: 3212
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby Stark Raving » Tue Dec 15, 2009 1:27 am

Hmmm. The info in the hook_gallery file says I can put the code in a template. What if I want to put it on a page? Sorry for the dumb questions. I'm not even sure how this extension is suppose to work. Let me see if there are any examples that others have posted using this extension. Thanks.
"After I'm dead I would rather have people ask why I have no monument than why I have one." ~ Cato the Elder

"In heaven all the interesting people are missing." ~ Friedrich Nietzsche
User avatar
Stark Raving
Silver Sponsor
 
Posts: 108
Joined: Tue Dec 11, 2007 9:24 pm
Location: Vancouver Island

Re: Uh Oh! Gallery Extension Made Web Site Disappear?

Postby hansfn » Tue Dec 15, 2009 8:45 am

Just try ... but this is really meant for people that use image galleries in many posts. If you only need it once, you might as well just use the fancybox extension and insert many popups.
hansfn
Developer
 
Posts: 3212
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Next

Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 1 guest