oEmbed extension

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Re: oEmbed extension

Postby Schop » Sun Apr 11, 2010 12:32 pm

hansfn wrote:NB! When you install the unstable release always grab the text file (next to the zip file) too so you know exactly which version you installed - the unstable release changes constantly, not only once every day/night.


Hans, why don't you inlude the number in the text file in the footer in the backend, to make it clearer which unstable release one is using?
User avatar
Schop
Contributor
 
Posts: 485
Joined: Mon Apr 21, 2008 1:47 pm
Location: Hudson, Ohio

Re: oEmbed extension

Postby jadwigo » Sun Apr 11, 2010 1:43 pm

PvC wrote:
jadwigo wrote:do you have an url where I can look at it?


Yes: http://www.ambientblog.net
(= http://www.vancooten.com/blog/ )

But you won't notice anything on the user's side I guess?



Ah.. that explains a lot - your jQuery is loaded in compatibility mode, the 0.7 version of oembed should have fixed that..
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby PvC » Wed Apr 14, 2010 7:39 pm

...but I'm afraid it didn't
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm

Re: oEmbed extension

Postby jadwigo » Thu Apr 15, 2010 6:02 am

could you publish a page on ambientblog.net somewhere with a youtube embed in it so I can look at the output?
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby PvC » Thu Apr 15, 2010 7:34 pm

Of Course, here it is. I dated it 2006 to keep it out of view.

http://www.vancooten.com/blog/?e=295

Bye
Peter
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm

Re: oEmbed extension

Postby jadwigo » Fri Apr 16, 2010 8:47 am

The source code tells me that oembed uses the fallback for the link:

Code: Select all
<p><a href="<a" class="oembed">loading something from default</a></p>


Which means the cache and possibly mysql is not working.
Also it looks like you're trying to embed a hyperlink and not an url.

Which is weird, did you use
Code: Select all
[[embed url="<a href="http://www.youtube.com/watch?v=Xac9Rnk9G-A">http://www.youtube.com/watch?v=Xac9Rnk9G-A</a>"]]

instead of
Code: Select all
[[embed url="http://www.youtube.com/watch?v=Xac9Rnk9G-A"]]


some browsers (I'm looking at MSIE here) like to replace URL's with hyperlinks.

On what server are you working now? The IIS or the Apache one?
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby PvC » Fri Apr 16, 2010 7:17 pm

As far as I know my webserver is Apache.

I did a small test and embedded the link with three different browsers.

IE immediately turns the URL into a hyperlink and totally corrupts the code: "<a" class="oembed"> is never correct in any way!

FF and Chrome insert the correct URL but the result still is a hyperlink displaying "loading something from default".

Am I the only one experiencing this?
In fact I never found it too annoying to include the complete <object> code, so I don't know why I bother with this extension at all.
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm

Re: oEmbed extension

Postby jadwigo » Mon Apr 19, 2010 7:55 am

maybe it'll work if you remove the broken link that internet explorer made - javascript likes to stop at the first unrecoverable error.
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby PvC » Mon Apr 19, 2010 6:10 pm

Nope, I'm sorry.
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm

Re: oEmbed extension

Postby jadwigo » Tue Apr 20, 2010 8:17 am

well.. at least the external links jquery script is working now.

Could you provide me with access to the pivotx backend so I can try to find what's wrong (PM or email to lodewijk at twokings dot nl)
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

PreviousNext

Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 2 guests

cron