oEmbed extension

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Re: oEmbed extension

Postby jadwigo » Mon May 03, 2010 2:09 pm

The problem was that internet explorer was rewriting links inside the rich text editor, and that was why the code would be entered as
Code: Select all
[[embed url="<a href="http://www.youtube.com/watch?v=Xac9Rnk9G-A">http://www.youtube.com/watch?v=Xac9Rnk9G-A</a>"]]

this resulted in invalid html, which broke jquery, which made the extension unable to do the oembed process.

--

In other news there's a new version in on the site (0.8)
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby jadwigo » Tue Aug 10, 2010 10:13 am

There's an updated version (0.9) on the site. This version should cleanup the cache every once in a while.
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby gwbonline » Tue Nov 16, 2010 1:00 pm

I activated the oEmbed extension and put the snippet in a template. It only produces a link (the url I set in the oEmbed snippet). Is this a know issue or am I doing something wrong?
gwbonline
 
Posts: 580
Joined: Tue Jan 01, 2008 5:17 pm

Re: oEmbed extension

Postby jadwigo » Tue Nov 16, 2010 1:34 pm

in some cases the snippet produces a link that will be rebuilt by jquery...
if your jquery is loaded correctly is will show the embedded content

in some other cases there is no embeddable resource known to the script, because the provider is new, or the target is not an oembed provider, in that case you will only see a link too
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby gwbonline » Tue Nov 16, 2010 1:49 pm

On the same page Fancybox (and Gallery) are active. They also use jquery and these scripts work fine. When oEmbed only produces a link, is it possible that it's because the creator of the movie decided to not let viewers embed it? There is no embed code available...
gwbonline
 
Posts: 580
Joined: Tue Jan 01, 2008 5:17 pm

Re: oEmbed extension

Postby jadwigo » Tue Nov 16, 2010 1:58 pm

that is a possibility, does it work if you try to embed another movie
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby djoeyb1 » Wed Feb 23, 2011 11:40 am

YouTube has updated their embed code. It's now a IFrame with support for the iPad.
But it doesn't work with Oembed. I can't see movies from YouTube on my iPad.
Can You make this?

Nederlands:
Volgens mij heeft YouTube hun embed code geüpdate. Want op mijn iPad kan ik de YouTube filmpjes niet bekijken terwijl dat eerst wel kon. De filmpjes kan ik wel zien op andere websites. Hoe Kan ik de YouTube filmpjes weer bekijken op mijn iPad?
djoeyb1
 
Posts: 3
Joined: Sun Feb 13, 2011 12:28 pm

Re: oEmbed extension

Postby jadwigo » Tue Jul 12, 2011 9:18 am

I updated the oembed extension to version 0.11

This only fixes a problem when the title of an embedded resource contains quotes - which would break the image alt tag.

As usual you can find it on: http://extensions.pivotx.net/entry/5/oembed
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

Re: oEmbed extension

Postby danielschut » Mon Mar 05, 2012 12:05 pm

Hi, I have a question regarding the oEmbed extension.

The situation: from my blog I want to embed a specific scene from The Daily Show. It's this scene:

http://www.thedailyshow.com/full-episodes/wed-february-29-2012-masha-gessen?userClipStartTime=194.4&userClipEndTime=274.174&startIndex=1

As you can see, the URL allows you to go to a specific place in the video: it's 12 minutes and 40 seconds into the second act.

However, whenever I use [[Embed url=" above mentioned url"]], the embedded video starts with the first second of act 1 and only includes act one, not the important part of act two.

I'm not sure what causes it and whether it's caused by oEmbed or by something the daily show does. Any typs would be very much appreciated.


PS: for other videos, oEmbed works amazingly well, thanks!
danielschut
 
Posts: 69
Joined: Tue Jun 02, 2009 4:42 pm

Re: oEmbed extension

Postby jadwigo » Tue Nov 06, 2012 8:52 am



The url for the second act uses get parameters, and they are not handled correctly in this case.
- I'm sorry for the late reply -


In other news, I updated the extension a bit so it handles image titles with quotes.
My pivotx playground is at http://jivotx.twokings.eu - the rest is at http://www.jadwigo.nl
jadwigo
Developer
 
Posts: 117
Joined: Wed Nov 18, 2009 9:49 am
Location: Den Haag, Netherlands

PreviousNext

Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 2 guests

cron