Slideshow extension

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Re: Slideshow extension

Postby hansfn » Wed Sep 22, 2010 8:34 pm

Harm, this is how it is in all software development - the source code management system (in our SVN) will contain many fixes that haven't been published/released. Regarding "Or maybe submits the same minor fix?" and similar problems - that's what bug/issue trackers are for. So if you want to improve this project you could start taking issues reported in the forum and adding them to our bug tracker. We did that some years ago, but it was just taking too much time - we basically use the forum as a bug tracker. Nope - it's not perfect.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Slideshow extension

Postby hansfn » Mon Sep 27, 2010 1:13 pm

I'm happy to announce version 0.7 of the Slideshow extension. It includes an improved version of the patch from ppescher (found earlier in this thread):

  • Fixed "orderby" bug.
  • Added support for getting images from all or leaf subdirectories (recursion).
  • Added support for using IPTC data in image title.
  • Updated docs - of course.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Slideshow extension

Postby Pim Horvers » Fri Dec 24, 2010 12:39 pm

Hope someone can help me out:
Have a problem with the time-out of the slideshow. Time-out set to 5000 millisecondes.
The problem is that the photos are sliding somethimes at the normal speed and after every photo going really fast.
Next to this sliding back isn't going smouth.

Page example can be found here:
http://www.pimhorvers.nl/page/portfolio-wedding

Thanks in advantage!

BR, Pim
Pim Horvers
 
Posts: 19
Joined: Fri Dec 24, 2010 1:51 am

Re: Slideshow extension

Postby Pim Horvers » Mon Dec 27, 2010 12:26 pm

No one can help me out during Christmas?
Pim Horvers
 
Posts: 19
Joined: Fri Dec 24, 2010 1:51 am

Re: Slideshow extension

Postby Harm10 » Mon Dec 27, 2010 2:17 pm

As all developers are volunteers you sometimes have to wait especially on special days........ ;)

Anyway the developer of this extension (not me) would want to know what version of PivotX you are running (I saw 2.1.2 in the page source) and probably also what parms you have set (not only the time-out).
I also saw in your page source this code
Code: Select all
<!-- voor laden galleria slideshow -->
<script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>
<script src="galleria/src/galleria.js"></script> 
You added that yourself? Maybe it influences the scripts that slideshow is using.....
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Slideshow extension

Postby Pim Horvers » Tue Dec 28, 2010 6:28 pm

Thanks for reacting!

The galleria slidshow script I deleted because this was 'n old script I tried to use with the flickr plug-in. But no changed to the problem after deleting.
Yes, Pivotx version 2.1.2. and params added as attachment.
Hope you can help me out..

BR, Pim


Attachments
screenshot.png
screenshot.png (80.33 KiB) Viewed 13027 times
Pim Horvers
 
Posts: 19
Joined: Fri Dec 24, 2010 1:51 am

Re: Slideshow extension

Postby Harm10 » Tue Dec 28, 2010 10:02 pm

Probably hansfn has to look at this (he did the last change to this extension).
I can see that the includes for slideshow are added twice to the page. In the head and in the body.
Where did you put the [[ slideshow ]] template?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Slideshow extension

Postby Pim Horvers » Wed Dec 29, 2010 11:27 pm

Works now.
You where right about the double inclides. This was creating the problem.
Thanks for your help!

BR, Pim
Pim Horvers
 
Posts: 19
Joined: Fri Dec 24, 2010 1:51 am

Re: Slideshow extension

Postby winters » Thu Feb 03, 2011 4:12 am

hi

would it be possible to build the option to stop de slideshow after 1 rotation?

thanks
willem
winters
 
Posts: 86
Joined: Thu Jan 13, 2011 9:09 pm

Re: Slideshow extension

Postby DiMTRX » Tue Mar 22, 2011 8:29 pm

Strange I cant seem to get the slide-show aligned properly with the wysi editor, even if i align it to the center or right side it keeps sticking to the left sides of my posts :S
User avatar
DiMTRX
 
Posts: 8
Joined: Tue Aug 18, 2009 4:57 pm
Location: Netherlands

PreviousNext

Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 3 guests

cron