Google Analytics works but doesnt update

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Google Analytics works but doesnt update

Postby PvC » Tue Mar 22, 2011 7:07 pm

After some tweaking I got Google Analytics extension to work; it shows fine in the dashboard now. But it does not seem to update - it keeps showing the initial result (that is the graph shows details up to 03-15, which is a week old now).
Anyone else seen this and know whats wrong?

Thanks
Peter
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm

Re: Google Analytics works but doesnt update

Postby Wim » Tue Mar 22, 2011 9:03 pm

PvC wrote:After some tweaking I got Google Analytics extension to work; it shows fine in the dashboard now. But it does not seem to update - it keeps showing the initial result (that is the graph shows details up to 03-15, which is a week old now).


I believe there should be a analytics.php in your db folder that gets generated by the scheduler. My guess: the scheduler encounters a problem creating this file or accessing your google analytics account. Anything listed amongst the 'events' on your dashboard?
User avatar
Wim
 
Posts: 59
Joined: Sun Dec 28, 2008 11:32 am

Re: Google Analytics works but doesnt update

Postby PvC » Wed Mar 23, 2011 6:40 pm

In fact, both could be true:

- the analytics.php file access rights on the server was 666; I chmodded it to 777 and will see what happens the next few days.

- when I click the test link in the analytics settings page, I get a login error, although the login and password are set correct. In fact I mostly get this error. Only once I managed to login this way, and thus was able to retrieve the profile ID. But most of the times I get the login error. Don't know how to fix that, since the login details are definitely correct.

Bye
Peter
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm

Re: Google Analytics works but doesnt update

Postby danielschut » Fri Jul 15, 2011 12:44 pm

@pvc: did this work? Mine isn't working either.
danielschut
 
Posts: 69
Joined: Tue Jun 02, 2009 4:42 pm

Re: Google Analytics works but doesnt update

Postby _Allen » Fri Aug 05, 2011 11:03 am

PvC wrote:- when I click the test link in the analytics settings page, I get a login error, although the login and password are set correct.


Same problem exists using PivotX svn 3827 with extensions also from svn 3827. According to the debug-mode:
Code: Select all
Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set. (in 'googleanalytics/analytics_api.php' on line 396)

Safe_mode is off, open_basedir has no value, curl 7.21.0 enabled (phpinfo)
User avatar
_Allen
 
Posts: 12
Joined: Tue May 18, 2010 3:20 pm
Location: Hungary

Re: Google Analytics works but doesnt update

Postby PvC » Mon Aug 08, 2011 9:14 am

danielschut wrote:@pvc: did this work? Mine isn't working either.


Yes, somehow around that time the Google Analytics panel started updating. Not sure if that was because of the CHMOD of due to a necesarry change update of PHP. Anyway, it works fine now.
PvC
 
Posts: 74
Joined: Wed Aug 19, 2009 12:07 pm


Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 3 guests

cron