Bonus Forms

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Re: Bonus Forms

Postby Sanzine » Fri May 23, 2014 12:44 pm

Yes! Thanks Hans, that did the trick!
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby Sanzine » Wed Jun 11, 2014 9:46 am

I have another question regarding the bonus form extension. Used it already several times on different PivotX sites, however on my latest website the mail isn't arriving at the info@[domain].nl address (same domain as on which the form is set-up). However, it is arriving at email addresses from other domains.

When asking the hosting provider, they mentioned that I have to put the sending of the mail from the form to external instead of internal. But I have no clue how to do that if at all possible.

How is this issue solved? Thanks in advance!
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby Sanzine » Thu Jun 19, 2014 6:55 pm

No-one to help me with my question?? :-(
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby Harm10 » Fri Jun 20, 2014 12:27 pm

Sanzine wrote:When asking the hosting provider, they mentioned that I have to put the sending of the mail from the form to external instead of internal. But I have no clue how to do that if at all possible.

I am willing to help but I do not understand what they mean as well.
But why should you have to change something that works in a lot of places? Maybe your hoster can set their settings in such a way that they are similar to the other hosters? Apparently somethings blocks the mailing?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Bonus Forms

Postby Sanzine » Tue Sep 02, 2014 8:52 am

I just seem to keep running into problems with the Bonus Form extension on the several websites I'm working on... And it is such a great extension!

Okay, new issue, new website: installed Bonus Forms extension. Set-up very simple form. All seems fine, but no e-mail is sent. Checked with to different mailaddresses. Debug log is not mentioning anything other than:

Code: Select all
: Only variables should be passed by reference. (in 'bonusforms/bonusforms_actions.php' on line 1240)


What could be the issue?

Thanks in advance for your help!
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby Harm10 » Wed Sep 03, 2014 6:37 pm

This error message points in the direction of strict mode for PHP. I am not that familiar with coping with these kind of things. There are a lot of references on the net about this. Perhaps you can switch it off on your server?
Alas I am lacking time to investigate properly.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Bonus Forms

Postby Sanzine » Thu Sep 04, 2014 7:14 am

Hi Harm,

When you mentioned strict mode for PHP I remembered posting another question regarding the bonus form extention on 23 May. In that case the email was however sent and the only issue was that the 'error' message was displayed. That was resolved by changing some code (see reply of hansfn).

Now the issue is that also the email isn't sent, which is a much bigger issue when using a contact form...

Any other ideas on this one?
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby Harm10 » Thu Sep 04, 2014 7:31 pm

Did you check the server error log?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Bonus Forms

Postby hansfn » Thu Sep 04, 2014 8:38 pm

Are you using the latest version of the extension - see http://extensions.pivotx.net/entry/49/bonusforms I can't find any matching code line in the newest version (0.15) for the message in your debug log.
hansfn
Developer
 
Posts: 3280
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Previous

Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 1 guest