Galleryimagelist not working

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Galleryimagelist not working

Postby Sanzine » Mon Dec 23, 2013 1:53 pm

When I upload images through the galleryimagelist on a page, the images all end up on the server (so they are correctly uploaded). However, when I save and close the page and open it again in the editor, there are no images in the galleryimagelist.

Also, they are not showing up on the page itself. I use the below code:

Code: Select all
[[bonusgallery assign='gallery' content=$page.extrafields.galleryimagelist fancybox='1']]
[[foreach from=$gallery item='image']]
    <a href="[[$image->src]]" class="fancybox" title="[[$image->title|escape]]" rel="[[$image->rel]]">
        <img src="[[$image->getImgSrc(150,113)]]" alt="[[$image->alt|escape]]"
            title="[[$image->title|escape]]" />
    </a>
[[/foreach]]


What's wrong?

Pivot 2.3.7
Bonus Fields 1.33
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Galleryimagelist not working

Postby Harm10 » Mon Dec 23, 2013 3:11 pm

What happens when you select the images you want to be part of the gallery (after all the images should now be uploaded)?
Are there any messages in the debug log?
And what happens when you use another browser?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Galleryimagelist not working

Postby Sanzine » Tue Dec 24, 2013 9:06 am

When I select the uploaded image, it does show in the page edit screen, but after saving it's gone again.

Debug log doesn't really mention anything (see below).

I have tried in Chrome, IE11 and FF.

2013-12-24 09:55:01 - 0.114 -- modules/module_upload.php:96 / _completeTemplateVars() -- ( 9108812 )
Plupload runtime order: html5,flash,silverlight,gears,browserplus
2013-12-24 09:55:02 - 0.043 -- pivotx/ajaxhelper.php:1045 / ext_logDebug() -- ( 8853828 )
plupload runtime used is "html5"
2013-12-24 09:55:48 - 0.084 -- modules/module_upload.php:96 / _completeTemplateVars() -- ( 9110476 )
Plupload runtime order: html5,flash,silverlight,gears,browserplus
2013-12-24 09:55:48 - 0.050 -- pivotx/ajaxhelper.php:1045 / ext_logDebug() -- ( 8855496 )
plupload runtime used is "html5"
2013-12-24 09:56:08 - 0.084 -- modules/module_upload.php:96 / _completeTemplateVars() -- ( 9113172 )
Plupload runtime order: html5,flash,silverlight,gears,browserplus
2013-12-24 09:56:08 - 0.042 -- pivotx/ajaxhelper.php:1045 / ext_logDebug() -- ( 8857720 )
plupload runtime used is "html5"
2013-12-24 09:56:53 - 0.149 -- pivotx/scheduler.php:126 / cleanCache() -- ( 9412060 )
Scheduler: deleted 16 cache files in 0.149 secs. 27 files were checked.
2013-12-24 09:57:05 - 0.072 -- modules/module_debug.php:414 / userErrorHandler() -- ( 8855592 )
Warning: Invalid argument supplied for foreach(). (in 'modules/entries_sql.php' on line 954)
Warning: array_merge() [function.array-merge]: Argument #2 is not an array. (in 'pivotx/pages.php' on line 241)
Warning: array_slice() [function.array-slice]: The first argument should be an array. (in 'pivotx/pages.php' on line 242)
Warning: Invalid argument supplied for foreach(). (in 'pivotx/pages.php' on line 246)
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Galleryimagelist not working

Postby Harm10 » Tue Dec 24, 2013 10:41 am

You do see a thumbnail after selecting the image for the imagelist?
Are your images located in main folder \images or a subfolder of that ?

Perhaps you can give me a temporary login so I can check?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Galleryimagelist not working

Postby Sanzine » Tue Dec 24, 2013 11:05 am

Yes, I do see a thumbnail when selecting the image. Images are uploaded to \images\yyyy-mm

I will send a PM with your temporary login.
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Galleryimagelist not working

Postby Harm10 » Tue Dec 24, 2013 12:29 pm

Checked the settings. You cannot use galleryimagelist from Bonusfields and extension Gallery at the same time.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Galleryimagelist not working

Postby Sanzine » Tue Dec 24, 2013 12:39 pm

Thanks Harm. Problem solved!
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am


Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 5 guests

cron