Skinny theme: tags not working

Discuss PivotX 2.0.x themes here, and view themes that are available for download.

Skinny theme: tags not working

Postby wietse » Tue Jun 18, 2013 6:31 pm

Hi, I am, using Skinny theme on the following blog: http://www.theblackfish.org/blog/ and when clicking on the tags, they bring up the error:

The requested URL /blogtag/passion was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Anyone any ideas on how I could fix this? I'm at a loss. Thanks for any help!
wietse
 
Posts: 8
Joined: Sun Jun 02, 2013 8:48 am

Re: Skinny theme: tags not working

Postby Harm10 » Tue Jun 18, 2013 9:40 pm

The links to your tags have a flaw: they miss a slash between blog and tag.
What kind of mod_rewrite did you choose? Did you create your own tag links or did you use the required tag templates for it?
What happens when you do not use mod_rewrite?
Does this problem also occur when using the default delivered weblog?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Skinny theme: tags not working

Postby hansfn » Wed Jun 19, 2013 8:28 am

This isn't related to tags (or mod_rewrite) - none of the links to archives, categories or tags work in the right menu.

The problem is that the root URL is missing an ending slash - see the "URL to Weblog" setting. PS! There is a warning for this setting: "Leave this field blank, unless you know what you are doing. If left empty, PivotX will automatically determine the URL of your weblog, which is usually the best option. Normally this setting is only used if you want one directory for each weblog."
hansfn
Developer
 
Posts: 3278
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Aaah: Many thanks for this one!!

Postby blausand » Fri Oct 11, 2013 5:35 am

Had to search a bit, though. :ugeek: To share the clue:
it's not the URL in the "admin>config" or "admin>extended" config, it's the one in the "administration>weblogs" page.
-=- using pivotX 2.3.6 -=- having multiSite installation -=- loving extensions -=- breaking free from fixed width bLog-layouts -=- adding wild js and css to templates -=-
blausand
 
Posts: 27
Joined: Wed Nov 18, 2009 4:27 am
Location: Cologne, Germany | twitter.com/@blausand


Return to 2.x Themes

Who is online

Users browsing this forum: No registered users and 2 guests