Change theme but no change on page?

Discuss PivotX 2.0.x themes here, and view themes that are available for download.

Change theme but no change on page?

Postby javonanka » Sat Aug 01, 2009 11:22 pm

Hi,

It appears that changing theme isn't running as smooth as expected. When I change the theme it does not update on the homepage, still same theme. Had that issue with some subweblogs, but then it all started to work. Now removed these subweblogs and want to run the same theme on the main weblog, have changed the theme but does not update.

Any ideas of why?


Cheers,
Johan
javonanka
 
Posts: 10
Joined: Wed Jun 10, 2009 10:30 am

Re: Change theme but no change on page?

Postby javonanka » Wed Aug 05, 2009 10:10 am

Playing around i've now realised how to change the theme of the pages. Initially i though by changing templates under weblog would change the theme, but now found that I also have to change theme for each page type.
javonanka
 
Posts: 10
Joined: Wed Jun 10, 2009 10:30 am

Re: Change theme but no change on page?

Postby hansfn » Tue Aug 11, 2009 9:38 am

That isn't 100% correct. If you don't select a template for your pages, it will use the settings in your weblog/theme as a default value.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Change theme but no change on page?

Postby bkksinga » Sun Oct 25, 2009 7:28 pm

I have a problem to submit. When i choose a template, this is meant for all the pages i suppose. So after i choose the template when i create the weblog, i have to see the same template applied on all the pages.
This happens with my first weblog. when i create the second weblog, i can see just the first page with the template i chose. all the other pages comes out with the template of the first weblog that i created.
I run pivotx on flat file.
I hope somebody can help me with this. Is there any mistake i do ?
Pino aka bkksinga
bkksinga
 
Posts: 17
Joined: Sun Jun 28, 2009 10:38 am
Location: Italy

Re: Change theme but no change on page?

Postby hansfn » Sun Oct 25, 2009 8:35 pm

First of all, a link to your site is always a good help. Secondly, you haven't told what version you are using.

Anyway, I recommend grabbing pivotx-latest.zip from http://pivotx.net/files/unstable-development/ and see if the problem is still present.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Change theme but no change on page?

Postby bkksinga » Wed Oct 28, 2009 5:14 pm

hansfn wrote:First of all, a link to your site is always a good help. Secondly, you haven't told what version you are using.

Anyway, I recommend grabbing pivotx-latest.zip from http://pivotx.net/files/unstable-development/ and see if the problem is still present.


http://singa.altervista.org/?w=letteratura
In this blog, when i move to the second page of entries, i have the same template of main weblog. Is it correct?
I have already updated the pivotx at last version.

thanks
bkksinga
 
Posts: 17
Joined: Sun Jun 28, 2009 10:38 am
Location: Italy

Re: Change theme but no change on page?

Postby bkksinga » Sat Oct 31, 2009 12:14 pm

bkksinga wrote:
hansfn wrote:First of all, a link to your site is always a good help. Secondly, you haven't told what version you are using.

Anyway, I recommend grabbing pivotx-latest.zip from http://pivotx.net/files/unstable-development/ and see if the problem is still present.


http://singa.altervista.org/?w=letteratura
In this blog, when i move to the second page of entries, i have the same template of main weblog. Is it correct?
I have already updated the pivotx at last version.

thanks


Sorry to come up again with this topic. But a problem is haunting me. Why when i change template and/or i make changes on template, these changes appear only on the first page and dont appear on following pages ? Where do i do wrong?
sorry again Pino
bkksinga
 
Posts: 17
Joined: Sun Jun 28, 2009 10:38 am
Location: Italy

Re: Change theme but no change on page?

Postby hansfn » Sat Oct 31, 2009 3:26 pm

Are you using output caching? Are the pages using the same template? And so on ...
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Change theme but no change on page?

Postby bkksinga » Sat Oct 31, 2009 5:30 pm

hansfn wrote:Are you using output caching? Are the pages using the same template? And so on ...


Thanks for your answer, but what is output caching? i cleaned the cache of my browser and cache in pivotx and i wateched the same from different internet points...
http://singa.altervista.org/
if you move through the pages of weblog (not the static pages) you will see:
on 1 pages i have threecolumns ... then on second pages just two columns. I added a include file in frontpage template.
it works just on first page ....
Pino
bkksinga
 
Posts: 17
Joined: Sun Jun 28, 2009 10:38 am
Location: Italy

Re: Change theme but no change on page?

Postby hansfn » Sat Oct 31, 2009 6:01 pm

if you move through the pages of weblog (not the static pages)

OK, you should have made that clear much earlier. I thought you were talking about your pages.

The reason is that your front page is using the frontpage template, but when you browse the pages in the weblog PivotX switch to the archivepage template ... If you want it to look the same, set the archivepage and frontpage template equal in the weblog configuration.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Next

Return to 2.x Themes

Who is online

Users browsing this forum: No registered users and 1 guest

cron