Notice: Undefined index: REQUEST_URI

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Notice: Undefined index: REQUEST_URI

Postby jellek » Thu May 26, 2011 10:18 am

Hi all,

search the bug forum did find more on this, but not specifically on the linenumber I get.

I made a new install, using pivotx 2.2.5. All works fine, but I get the annoying message:
Notice: Undefined index: REQUEST_URI in D:\www\koningglobal.com\www\blog\pivotx\modules\module_tags.php(1021) : eval()'d code on line 1

By default this is on the top of my screen, when logged on to the dashboard. Similar messages appear whenever I try to change something.

Funny thing is, everything works fine. The website does... etc.

I am normally using google chrome, but firefox shows the same message.

If you need more info, pleas contact me

I have put the phpinfo file as you asked here: http://www.koningglobal.com/phpinfo.php. pivotx is running in a subdir named /blog
jellek
 
Posts: 8
Joined: Fri Oct 10, 2008 7:23 pm

Re: Notice: Undefined index: REQUEST_URI

Postby Harm10 » Thu May 26, 2011 11:49 am

Version 2.2.6 is currently downloadable from the site http://pivotx.net/.
Please try that one.
And btw I don't get that notice when I look at the blog link.

Btw2: your mail addresses are readable in the source. Better use encode_email_addresses
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Notice: Undefined index: REQUEST_URI

Postby hansfn » Thu May 26, 2011 1:14 pm

There are two issues here:

  • jellek is using a server (IIS?) that doesn't define REQUEST_URI. PivotX is using that variable three places so it could potentially be a problem, and it's worth an entry in our bug tracker. Harm, can you add it? (Wordpress, Drupal and so on works around this short-coming of IIS so I guess PivotX should do it too.)
  • Since this is mostly an annoying notice, please consider changing the error reporting level in the PHP configuration (error_reporting) and/or stop display errors on screen and just log them to file (display_errors).
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Notice: Undefined index: REQUEST_URI

Postby Harm10 » Thu May 26, 2011 1:51 pm

hansfn wrote:jellek is using a server (IIS?) that doesn't define REQUEST_URI. PivotX is using that variable three places so it could potentially be a problem, and it's worth an entry in our bug tracker. Harm, can you add it?.[/list]
Added!
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Notice: Undefined index: REQUEST_URI

Postby jellek » Fri May 27, 2011 6:15 am

Thanks for the incredible fast responses. I hope it is solved in some of the next releases.

You mentioned you did not get the message on the blog link. That is correct, the blog works fine. Only in the administrator environment I get the message.

When clicking on the "external feeds" like google etc on the "tag-page" I get the same message:
"Notice: Undefined index: REQUEST_URI in D:\www\koningglobal.com\www\blog\pivotx\modules\module_tags.php(1021) : eval()'d code on line 1 Warning: MagpieRSS: Failed to parse RSS file. (Invalid character at line 19, column 80) in D:\www\koningglobal.com\www\blog\pivotx\includes\magpie\rss_fetch.inc on line 239
Oeps! Het lijkt er op dat ik de Tag Feed niet kon ophalen.
Geen resultaat op blogsearch.google.com voor blogInvalid character at line 19, column 80"


Thanks again!

regards
Jelle
jellek
 
Posts: 8
Joined: Fri Oct 10, 2008 7:23 pm

Re: Notice: Undefined index: REQUEST_URI

Postby jellek » Sat May 28, 2011 7:24 am

HI all,

just installed 2.2.6... problem allready solved?

Seems to work now.

On the external feeds I get a new error though

Warning: MagpieRSS: Failed to parse RSS file. (Invalid character at line 13, column 33) in D:\www\koningglobal.com\www\blog\pivotx\includes\magpie\rss_fetch.inc on line 239
Oeps! Het lijkt er op dat ik de Tag Feed niet kon ophalen.

Geen resultaat op blogsearch.google.com voor boekInvalid character at line 13, column 33

thanks
jellek
 
Posts: 8
Joined: Fri Oct 10, 2008 7:23 pm

Re: Notice: Undefined index: REQUEST_URI

Postby hansfn » Mon May 30, 2011 9:24 am

As far as I know nothing has changed with REQUEST_URI in version 2.2.6 compared to 2.2.5.

Regarding the magpie error: Some times there are errors in XML feeds - nothing we can do about it.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway


Return to 2.x Bugs

Who is online

Users browsing this forum: No registered users and 3 guests

cron