Why do not you support the Chinese search?

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Why do not you support the Chinese search?

Postby infokid » Fri Aug 03, 2012 11:51 am

Does not support the Chinese search.

Version 2.3.3
infokid
 
Posts: 5
Joined: Fri Aug 03, 2012 11:46 am

Re: Why do not you support the Chinese search?

Postby Harm10 » Fri Aug 03, 2012 12:12 pm

Perhaps you can explain more elaborate what you mean? Possibly with an example on how it should go or what goes wrong.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Why do not you support the Chinese search?

Postby infokid » Fri Aug 03, 2012 12:27 pm

Search engine doesn't work when i use chinese words as keywords for searching, english words is OK.
infokid
 
Posts: 5
Joined: Fri Aug 03, 2012 11:46 am

Re: Why do not you support the Chinese search?

Postby Harm10 » Fri Aug 03, 2012 1:55 pm

I guess your site is utf-8? And are the chinese words defined in the tags?
Do you have a site link for us?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Why do not you support the Chinese search?

Postby infokid » Fri Aug 03, 2012 2:04 pm

site and mysql is utf-8.

I tested in the local environment, not uploaded to the server.

Wait, I uploaded to the server.
infokid
 
Posts: 5
Joined: Fri Aug 03, 2012 11:46 am

Re: Why do not you support the Chinese search?

Postby infokid » Fri Aug 03, 2012 3:26 pm

Already installed

zjhw.net
infokid
 
Posts: 5
Joined: Fri Aug 03, 2012 11:46 am

Re: Why do not you support the Chinese search?

Postby Harm10 » Fri Aug 03, 2012 7:48 pm

This is very weird. The search string disappears along the way. Normally you can see the search string after the q= parm in the URL but when using Chinese characters they are gone.
This does not happen when the w= parm is behind it. As I cannot read those characters and cannot conclude whether something that should be found is inputed: could you try to switch on para_weblog_always http://book.pivotx.net/page/app-a
That should take care of always putting the weblog parm (w=) in the URL.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Why do not you support the Chinese search?

Postby infokid » Sat Aug 04, 2012 4:01 am

Relevant information has been PM.
infokid
 
Posts: 5
Joined: Fri Aug 03, 2012 11:46 am

Re: Why do not you support the Chinese search?

Postby hansfn » Sat Aug 04, 2012 10:41 am

Chinese search isn't supported. We just haven't had time to implement it. I might have some patches lying around - will take a look. (The "problem" is to update the search to work for Chinese while not breaking the search for "normal" languages with multi-letter words.)
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Why do not you support the Chinese search?

Postby Harm10 » Sat Aug 04, 2012 11:15 am

Would it be an idea that infokid sent you the logon credentials through PM (I can also forward them)? So you can test? Or is this not necessary?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Next

Return to 2.x Bugs

Who is online

Users browsing this forum: MSN [Bot] and 1 guest

cron