Comment form not showing on entry page

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Comment form not showing on entry page

Postby kithead » Sun Aug 24, 2008 4:09 am

Hello folks!

I just installed pivotx beta 1.10, upgraded all my entries and it all looks really good! Thanks for all your hard work.

Now, I'm not sure whether it's a permissions issue or a importing entries problem, but I am unable to see the comment entry box(es). I've enabled commenting by default, moderation is off, each individual entry allows commenting. There is no safe-mode warning. I'm using a flat-file system and am using the default template. Even when I swap entrypage templates, the comments form still does not show. I've tried Firefox and Safari, neither show the comment form.

Would anyone have any idea what's happening? I am beginning to suspect it has something to do with the importation of all my entries from the old pivot.

Here is what it looks like:
http://mscranky.com/?e=437
kithead
 
Posts: 2
Joined: Sun Aug 24, 2008 3:58 am

Re: Comment form not showing on entry page

Postby Bob » Sun Aug 24, 2008 10:44 am

Hi,

Does it make a difference, if you edit an existing entry, or if you post a new one?
Is the file templates/_sub_commentform.html still present on the new blog?
Did you enable debug, to see if anything is logged there?

One other thing: I see that you've added the slideshow widget, but it can't find jquery. Go to 'advanced configuration' and add 'always_jquery' with a value of 1.
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: Comment form not showing on entry page

Postby zeroshin » Sun Aug 24, 2008 1:58 pm

hi,

I have the same problem with beta 1.10

The comment form is not showing both for old and new entries.
The "sub_commentform.html" is still in the right folder.
Debug enabled but not giving messages about this,

Now I reversed to 1.9 and everything is working fine.

I don't know if it could be useful to resolve this, but I upgraded directly from 1.8 to 1.10, skipping 1.9.
zeroshin
 
Posts: 31
Joined: Mon Dec 10, 2007 8:49 pm

Re: Comment form not showing on entry page

Postby Bob » Sun Aug 24, 2008 2:45 pm

Oh, scratch that.. I wasn't able to reproduce it after all. Kithead: if looking at the debug log doesn't give any meaningful info, could you please edit pivot/modules/module_smarty.php, and remove these two lines, around line 507.

Code: Select all
    // This tag is only allowed on entrypages..
    if ( $PIVOTX['parser']->modifier['pagetype'] != "entry" ) { return; }
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: Comment form not showing on entry page

Postby kithead » Sun Aug 24, 2008 5:32 pm

Nothing in the logfile is showing anything strange other than something with tags (which is expected, I haven't tagged anything).

AHA!! Yes, commenting out the line you specified fixed it. Hurray!

Thank you very much!
kithead
 
Posts: 2
Joined: Sun Aug 24, 2008 3:58 am

Re: Comment form not showing on entry page

Postby zeroshin » Sun Aug 24, 2008 9:31 pm

I fixed this too, thank you
zeroshin
 
Posts: 31
Joined: Mon Dec 10, 2007 8:49 pm

Re: Comment form not showing on entry page

Postby Bob » Mon Aug 25, 2008 9:02 am

Ok, this does mean that something else is going on though.. In those pages, the 'pagetype' really should be "entry", to signify the type of page.

Could i get Pivot and FTP access to either one of your sites? Then i can see why the pagetype is set wrong, and fix it.
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: Comment form not showing on entry page

Postby Bob » Mon Aug 25, 2008 7:52 pm

Found the bug! Thanks, Alice!

(for others encountering this: there will be a 'beta 11', later tonight, which will fix this problem!)
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm


Return to 2.x Bugs

Who is online

Users browsing this forum: No registered users and 4 guests

cron