Issues with the Pivot Insert/edit Image tool...

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Issues with the Pivot Insert/edit Image tool...

Postby bretrooks » Tue Sep 23, 2008 8:48 pm

When using the Insert/edit Image tool to drop a Pivot tag for an image into a post, the changes made to the formatting in the popup window (border, alignment, etc.) are reflected in the wysiwyg editor but not in the HTML editor, and the settings do not make it into the published post.

I've also read that HTML tags for image location/placement are being deprecated in favor of CSS formatting. Is there a way to make this work with the current editor, or should I just refrain from using the tool for now?

Thanks for all your hard work,
Bret
PivotX 2.0 / MySQL / PHP 5.2.6
bretrooks
 
Posts: 25
Joined: Sun Jun 08, 2008 12:38 am

Re: Issues with the Pivot Insert/edit Image tool...

Postby Bob » Tue Sep 30, 2008 5:10 pm

bretrooks wrote:When using the Insert/edit Image tool to drop a Pivot tag for an image into a post, the changes made to the formatting in the popup window (border, alignment, etc.) are reflected in the wysiwyg editor but not in the HTML editor, and the settings do not make it into the published post.


As far as i can tell, this works correctly.. You mean the inserting of the [[image bla bla]] tag, right? If you're sure it's broken, could you be more specific, so i get a better idea of what's going on?

I've also read that HTML tags for image location/placement are being deprecated in favor of CSS formatting. Is there a way to make this work with the current editor, or should I just refrain from using the tool for now?


The idea is to make PivotX generate HTML that is as generic as possible, and then have the Templates apply style/layout to them. What exactly is there that the wysywig editor inserts, that you can't override in the templates themselves?
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: Issues with the Pivot Insert/edit Image tool...

Postby bretrooks » Tue Sep 30, 2008 8:30 pm

Not the [[image]] tag, but an embedded image using the html <img> tag. It shows up correctly in the wysiwyg window, and shows image information (e.g. pixel dimensions) correctly, but changes made using the popup tool don't seem to stick.

For example, when using the tool to change the alignment field from blank to "Left," the wysiwyg editor would correctly adjust the alignment in the view window. However, viewing the html source in the editor reveals that nothing has been changed, and publishing the post also shows that the changes didn't stick.

Also, the wysiwyg editor seems to strip out (or maybe just ignore?) tags that the image editor doesn't understand. I switched to Textile and added 'style="float: left; padding: 0em 1em 0em 0em' to the image tag and then looked at it again using the wysiwyg editor. The popup tool didn't report the change, which is to be expected since there are no options for inline css, but when I hit the html button the style entry didn't show up in the source at all.

The image formatting issue is mostly in that I expect to have differing alignments and text wraps for various images, and don't have a lot of experience in setting up templates to handle those sorts of varying options. I think inline CSS might be easiest for now.

Thanks,
Bret
PivotX 2.0 / MySQL / PHP 5.2.6
bretrooks
 
Posts: 25
Joined: Sun Jun 08, 2008 12:38 am


Return to 2.x Bugs

Who is online

Users browsing this forum: No registered users and 3 guests

cron