Could this be a bug?

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Could this be a bug?

Postby RaVlaNa » Thu May 22, 2014 1:13 pm

Hi,
lately I have noticed that, when you insert a picture in a post and you align it to the left, if you put any further text underneath it, the text is placed to the right of the picture.
Even when you put <br> in the HTML, this does not change.

The fault does not occur when the picture is centered, though.

Any chance of looking into that?

I use PivotX 2.3.9.
By the way, the same problem occurs with tags.
Thanks.
RaVlaNa
 
Posts: 81
Joined: Fri Jan 17, 2014 5:06 pm

Re: Could this be a bug?

Postby Harm10 » Fri May 23, 2014 7:14 am

This is not an error but normal behaviour. Whenever an image is centered it is assumed that any text should be positioned underneath it.
For images on the side the assumption is that text flows around the picture.
If you want to force the text to go under the image you could use breaks but then you need more than 1 and the effect is not guaranteed.
The best way to get text under your image is to edit the underlying html and add
Code: Select all
style="clear: both;"
to the html tag starting the text.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)


Return to 2.x Bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron