Strict Standards - PHP 5.2 vs PHP 5.5

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Re: Strict Standards - PHP 5.2 vs PHP 5.5

Postby Jost aus Soest » Sun Sep 21, 2014 8:14 am

Thanx a lot for your advice!

If PivotX serves your needs, you can probably use it for 2-3 more years without other problems than what you have already experienced.

I've found other strict errors while editing articles (e. g. inserting pictures), which were not hideable with the php.ini. (?!)
So I had to change the code in lib.php/makeUploadFolder:2704 and Smarty_Compiler.class.php/_compile_file:400.

SQLite, a single file database (no server needed), which is included in all recent versions of PHP.

I wasn't sure of that! So it's a real hope to switch to Bolt...

There is an incomplete upgrade path from PivotX to Bolt.

... in (hopefully) near future.

BTW: Your "SourceForge donation page" is not working!
Jost aus Soest
 
Posts: 21
Joined: Fri Sep 14, 2012 8:00 am
Location: Soest (Germany)

Re: Strict Standards - PHP 5.2 vs PHP 5.5

Postby hansfn » Sun Sep 21, 2014 10:39 pm

Jost aus Soest wrote:I've found other strict errors while editing articles (e. g. inserting pictures), which were not hideable with the php.ini. (?!)
So I had to change the code in lib.php/makeUploadFolder:2704 and Smarty_Compiler.class.php/_compile_file:400.


Hm, I just tested for myself and with display_errors off no messages are displayed - I tried inserting a picture while editing. Maybe explain in more detail exactly how you get the warnings to display? And the warning itself. Could you also please send me your lib.php and Smarty_Compiler.class.php so I can see which changes you made.

Jost aus Soest wrote:BTW: Your "SourceForge donation page" is not working!


Thx.
hansfn
Developer
 
Posts: 3278
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Strict Standards - PHP 5.2 vs PHP 5.5

Postby Jost aus Soest » Mon Sep 22, 2014 6:22 am

When I tried to insert a picture (using the Pic+-Button), in the popup window were immediately shown the already known strict errors ("Strict Standards: getdate(): It is not safe to rely ..."), which makes the form nearly unusable.
BTW: I've put the php.ini-file in almost every subfolder of the pivotx-system, but (without code modification) this hides only some of the errors in the popup window.

I'm sending the changed files and my php.ini to your pivotx-account.
Jost aus Soest
 
Posts: 21
Joined: Fri Sep 14, 2012 8:00 am
Location: Soest (Germany)

Previous

Return to 2.x Bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron