Only articles from standard-00100 are shown?

This is the place to discuss bugs that have been found in the most recent version of PivotX. Posting bugs will ensure that the Development Team is aware of them and that they will be addressed when resources are available.

Only articles from standard-00100 are shown?

Postby Jost aus Soest » Sat Dec 19, 2015 12:50 pm

I'm not sure, when this problem began. But now I can see on my blog - http://blog.123soest.de/ - only the articles in standard-00100 (flat file db).
All the old items in standard-00000 are not more available. :(
What's going wrong?

BTW: When I'm in the dashboard as admin, I can see and access only articles 100 to 120 (the newest). All the others are not available, but the page indicators has room for all (old) articles: "1 2 3 4 5 ... 6"
But this numbers leads to empty pages...

My phpinfo: http://blog.123soest.de/pivotx/phpinfo.php
Jost aus Soest
 
Posts: 21
Joined: Fri Sep 14, 2012 8:00 am
Location: Soest (Germany)

Re: Only articles from standard-00100 are shown?

Postby Harm10 » Sat Dec 26, 2015 11:52 pm

Have you tried to rebuild the index? It is under Administration / Maintenance.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Only articles from standard-00100 are shown?

Postby Jost aus Soest » Sun Dec 27, 2015 8:59 am

Harm10 wrote:Have you tried to rebuild the index? It is under Administration / Maintenance.


I havn't done this, because I fear that I loose the old data.

OK, I will try...

(bibber)

Done.

And...

YES! :D

Thank you very much, everything came back!
Jost aus Soest
 
Posts: 21
Joined: Fri Sep 14, 2012 8:00 am
Location: Soest (Germany)

Re: Only articles from standard-00100 are shown?

Postby Jost aus Soest » Sun Dec 27, 2015 9:02 am

After 5 years that was the first time, the index wasn't in order.
But where does the problem came from?
Jost aus Soest
 
Posts: 21
Joined: Fri Sep 14, 2012 8:00 am
Location: Soest (Germany)

Re: Only articles from standard-00100 are shown?

Postby Harm10 » Sun Dec 27, 2015 10:22 am

Jost aus Soest wrote:But where does the problem came from?

That is hard to say. Flat file isn't used that much as MySQL databases are around everywhere.
All I only know is that with a specific update the index can get corrupt (as are the other indexes). So a long time ago the rebuild options were created.
No risk to execute them btw. Did you also rebuild the other 2?
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2010
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Only articles from standard-00100 are shown?

Postby Jost aus Soest » Sun Dec 27, 2015 11:02 am

I cleared the cache and rebuild all 3 indexes (one after the other).

Thank you very much for your help!
(I know, it's the old system, but in general pivotx is running great...)
Jost aus Soest
 
Posts: 21
Joined: Fri Sep 14, 2012 8:00 am
Location: Soest (Germany)


Return to 2.x Bugs

Who is online

Users browsing this forum: No registered users and 4 guests

cron