Page 1 of 1

Only articles from standard-00100 are shown?

PostPosted: Sat Dec 19, 2015 12:50 pm
by Jost aus Soest
I'm not sure, when this problem began. But now I can see on my blog - http://blog.123soest.de/ - only the articles in standard-00100 (flat file db).
All the old items in standard-00000 are not more available. :(
What's going wrong?

BTW: When I'm in the dashboard as admin, I can see and access only articles 100 to 120 (the newest). All the others are not available, but the page indicators has room for all (old) articles: "1 2 3 4 5 ... 6"
But this numbers leads to empty pages...

My phpinfo: http://blog.123soest.de/pivotx/phpinfo.php

Re: Only articles from standard-00100 are shown?

PostPosted: Sat Dec 26, 2015 11:52 pm
by Harm10
Have you tried to rebuild the index? It is under Administration / Maintenance.

Re: Only articles from standard-00100 are shown?

PostPosted: Sun Dec 27, 2015 8:59 am
by Jost aus Soest
Harm10 wrote:Have you tried to rebuild the index? It is under Administration / Maintenance.


I havn't done this, because I fear that I loose the old data.

OK, I will try...

(bibber)

Done.

And...

YES! :D

Thank you very much, everything came back!

Re: Only articles from standard-00100 are shown?

PostPosted: Sun Dec 27, 2015 9:02 am
by Jost aus Soest
After 5 years that was the first time, the index wasn't in order.
But where does the problem came from?

Re: Only articles from standard-00100 are shown?

PostPosted: Sun Dec 27, 2015 10:22 am
by Harm10
Jost aus Soest wrote:But where does the problem came from?

That is hard to say. Flat file isn't used that much as MySQL databases are around everywhere.
All I only know is that with a specific update the index can get corrupt (as are the other indexes). So a long time ago the rebuild options were created.
No risk to execute them btw. Did you also rebuild the other 2?

Re: Only articles from standard-00100 are shown?

PostPosted: Sun Dec 27, 2015 11:02 am
by Jost aus Soest
I cleared the cache and rebuild all 3 indexes (one after the other).

Thank you very much for your help!
(I know, it's the old system, but in general pivotx is running great...)