Bolt on 'Cloud Hosting' errors.

A forum for Bolt related questions / issues

Bolt on 'Cloud Hosting' errors.

Postby James » Fri Mar 07, 2014 4:34 am

Hi there.

Recently been working on a site for a client, using Bolt as the CMS. I developed the site locally and hosted it on my own site with no problems (my own site uses the CPanel system). However I am now trying to get the website up and running on the clients hosting which is called 'Cloud Hosting'.

The host is running PHP 5.4.16, but after I upload the files and access the site on the domain I get these errors:

Code: Select all
Warning: is_dir(): Unable to find the wrapper "tcp" - did you forget to enable it when you configured PHP? in /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/Handler/NativeFileSessionHandler.php on line 51

Warning: is_dir(): Unable to find the wrapper "tcp" - did you forget to enable it when you configured PHP? in /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/Handler/NativeFileSessionHandler.php on line 51

Warning: mkdir(): Unable to find the wrapper "tcp" - did you forget to enable it when you configured PHP? in /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/Handler/NativeFileSessionHandler.php on line 52

Warning: mkdir(): File exists in /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/Handler/NativeFileSessionHandler.php on line 52

Fatal error: Uncaught exception 'RuntimeException' with message 'Failed to start the session because headers have already been sent by "/clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/Handler/NativeFileSessionHandler.php" at line 51.' in /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/NativeSessionStorage.php:143 Stack trace: #0 /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/NativeSessionStorage.php(281): Symfony\Component\HttpFoundation\Session\Storage\NativeSessionStorage->start() #1 /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Session.php(81): Symfony\Component\HttpFoundation\Session\Storage\NativeSessionStorage->getBag('attributes') #2 /clientdata/apache-www/m/e/sitename/www/app/src/Bolt/Application.php(296): in /clientdata/apache-www/m/e/sitename/www/vendor/symfony/http-foundation/Symfony/Component/HttpFoundation/Session/Storage/NativeSessionStorage.php on line 143


I have been unable to figure out how to correct this error. I have also chatted to the support of my host and they were unable to help me.

If anyone has any ideas that'd be much appreciated.

Thanks.
James
 
Posts: 1
Joined: Fri Mar 07, 2014 4:26 am

Re: Bolt on 'Cloud Hosting' errors.

Postby hansfn » Fri Mar 07, 2014 8:49 am

I wonder if the problem is session.save_path (or maybe another setting) in php.ini that is using "tcp" as protocol? Ask your hoster. Anyway, the last fatal error ('Failed to start the session because headers have already sent') is just a consequence of the is_dir warnings - the warnings are displayed in the web browser, right? You aren't copying these errors from the webserver error log?

PS! You might be able to "solve" this issue by simply stopping the display of errors - set display_errors to Off off in php.ini. (Setting this to off is strongly recommended.) You probably need to ask your hoster for this - or insert
ini_set('display_errors', 'Off'); in the beginning of the Bolt index.php file.
hansfn
Developer
 
Posts: 3280
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway


Return to Bolt Discussion

Who is online

Users browsing this forum: No registered users and 3 guests

cron