Page 1 of 1

Error: /bolt/bolt/users/edit/ was not found

PostPosted: Tue Jun 03, 2014 9:57 pm
by michalurban

I tried installing Bolt few times but always, after finishing the process, I end up with "The requested URL /bolt/bolt/users/edit/ was not found on this server." Ill tell you what I did:

1) Installation.
- Im running Ubuntu 14.04 32bit with Apache2, PHP5 and MySQL. Server IP is
- Using phpmyadmin I created mysql user bolt, database bolt, password bolt.
- I tried to install Bolt into bolt subdirectory under my servers root directory, so I did this:
Code: Select all
mkdir bolt
cd bolt
tar -xzf bolt_latest.tgz
rm bolt_latest.tgz
chmod 777 -R files/ app/database/ app/cache/ app/config/ theme/
cp app/config/config.yml.dist app/config/config.yml
nano app/config/config.yml
# here I changed the information about database to this:
  driver: mysql
  username: bolt
  password: bolt
  databasename: bolt

Before the last part the address kept showing me errors (like bad database driver and such). After the last part I ended up with "The requested URL /bolt/bolt/users/edit/ was not found on this server." The directory really wasnt there.

At this part I decided this was most likely the fault of Bolt so I moved on. BUT ... I ended up with same problems with other CMS systems ... Anchor and Redaxscript to mentions just two. So, I came back to Bolt and tried to check my servers setting.

2) I found out that the directories (like /bolt/bolt/users/edit/) dont really need to be in the directory tree: "There is no folder because it uses mod_rewrite to route everything through the index.php file." (as it says in some of the forums I visited).

So I tried to check if mod_rewrite is configured fine on my server. First, I did:
Code: Select all
> a2enmod rewrite
Module rewrite already enabled

Then, I read somewhere, that
Code: Select all
What a2enmod does is simply create a symbolic link, so the following two are the same, both proper, solution:
ln -s /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled/

So I checked if the file /etc/apache2/mods-enabled/rewrite.load is present (and it is).

And finally, I tried to find out other ways to check this. So, I tried making a PHP file with this content ...
Code: Select all
 if(!function_exists('apache_get_modules') ){ phpinfo(); exit; }
 $res = 'Module Unavailable';
 $res = 'Module Available';
<title>A mod_rewrite availability check !</title></head>
<p><?php echo apache_get_version(),"</p><p>mod_rewrite $res"; ?></p>

... and running it. The answer is: "mod_rewrite Module Available".

3) So, now im royally f*cked, unless of course some of you helps me ... I have no idea what to do now.

Thanks in advance! :)

Re: Error: /bolt/bolt/users/edit/ was not found

PostPosted: Wed Jun 04, 2014 9:06 am
by ningus
Hello Michal,

there is something unusual right at the beginning of your process, you created user bolt in phpmyadmin, if I’m not mistaken this should be root user of your mysql. No need to have explicit db user for any cms.


Re: Error: /bolt/bolt/users/edit/ was not found

PostPosted: Wed Jun 04, 2014 2:25 pm
by dpfavand
There's no absolute need to create a specific db user for a cms, but it's often a good idea to limit db access per application to just what that application needs. I don't think that's the problem here at all.

I suspect there's a problem with running Bolt in a subdirectory. This isn't something I've tried to do yet, and I'm not terribly experienced with Bolt yet so this may lead nowhere, but my first instinct would be to repeat your steps in the root directory of your server so that you can access it with just (not ). What happens when you do that?

Re: Error: /bolt/bolt/users/edit/ was not found

PostPosted: Wed Jun 04, 2014 3:04 pm
by dpfavand
Just found something possibly relevant:
In some cases it won’t work without the RewriteBase line, and in some cases it won’t work with it, depending on how your Apache is configured and the location on your site on the server. Isn’t Apache configuration great? :-)

Anyhow, if your site doesn’t work, try uncommenting the RewriteBase line and set it to the correct folder. For instance, if your Bolt site is located at, set it to RewriteBase /test/.

So try uncommenting the RewriteBase line in .htaccess and setting it to:
Code: Select all
RewriteBase /bolt/

Again, this is just where I would start if I were troubleshooting; results not guaranteed.

Re: Error: /bolt/bolt/users/edit/ was not found

PostPosted: Thu Jun 05, 2014 10:07 am
by michalurban
Todal, I tried checking and changing cofigs again and it looks like I may had some mixup in some of the config files ... and finally I got it working. The mess was probably with stuff configured on more than one place. Thanks for your reply anyway! :)

PS: I always use a new mysql user and a new database when adding a new CMS/gallery/whatever. I dont like using root account everywhere.

Re: Error: /bolt/bolt/users/edit/ was not found

PostPosted: Thu Jun 05, 2014 12:10 pm
by ningus
Glad it works now!

And thank you both for commenting on having dedicated mysql users, this makes me think again, even if it is for dev machines.

Re: Error: /bolt/bolt/users/edit/ was not found

PostPosted: Thu Jun 05, 2014 8:08 pm
by dpfavand
Glad to hear you got it sorted out, thanks for letting us know.