Page 1 of 1

Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 8:09 am
by Dorien
Hi!

When i create multiple contenttypes the dropdown nav in the cms changes to where you can not create a new entry right there in the menu. It just shows you the contenttypes, is this a bug or is it just when you have multiple contenttypes you cannot make a new one from the menu.

(in Dutch, vind het moeilijk uit te leggen in het Engels. Maar als je dus over inhoud hovered in het cms dan krijg je normaal een lijstje met contenttypes en dan een regeltje daaronder 'maak een nieuwe' maar nu heb ik 5 contenttypes in het menu staan en zie ik die maak een nieuwe niet meer. Is dat opzettelijk omdat anders het menu heel lang kan worden, of is het een bug?)

~ Dorien

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 9:14 am
by jhice
Hi,

Could you make a screenshot of this ?

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 9:45 am
by Dorien
So normally i would see the '+ new news item' or any other contenttype

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 10:04 am
by jhice
Okay, thanks.

Did you update your database ?

If not, go to "Dashboard" it shows you a message to update the database, click on it and on the button to create the listed tables.
I did a try and got your behavior only when I don't update the database.

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 10:31 am
by Dorien
I have updated the database several times now, since i edited the contenttypes a few times. But still not getting the + new ... buttons

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 10:45 am
by jhice
Ah,

It seems that from 4 to 5 items, the link "Add contentype" just dissapear.
In my test, I had only 5 links now and no "Add" link...

EDIT : until 4 contenttypes you have the "New" link, from 5 it dissapears

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 11:15 am
by Dorien
Allright, thanks for checking it out :)

Re: Multiple contenttypes menu

PostPosted: Thu Sep 18, 2014 11:18 am
by jhice
You're welcome ;) don't hesitate to add [Solved] before the title of your post