Page 1 of 1

browse/0 = browse/1

PostPosted: Fri Dec 16, 2011 2:00 pm
by ktbre
The "digg" function lists the same selection of posts for page 1 (URL:.../browse/0) and page 2 (URL:.../browse/1) when browsing.
The actual second page of posts is listed first when going to page 3 (URL:.../browse/2).
I'm using Pivotx 2.3.1 and the "bare bones" template, which has this entering in the frontpage_template.html:
[[ paging action="digg" ]]

Any ideas?

Re: browse/0 = browse/1

PostPosted: Fri Dec 16, 2011 6:45 pm
by Harm10
To rule out template failures please try the default theme which also digg paging on the frontpage.

Re: browse/0 = browse/1

PostPosted: Sat Dec 17, 2011 1:42 pm
by ktbre
I have tried the default template now, same results. I've also reindexed through maintenance menu, and cleared the cache.

But I did some experimenting with a test installation, and it seems the problem occures when you create blog posts for future publishing. For instance, if I register one post for future publishing, this affects the output of the second page of browsing ("browse/1"), seems like this page treats the unpublished (future) post as already published and visible on the first page. If I register more posts for future publishing, the second browse page ("browse/1") will eventually display the same posts as the front page, or first browse page ("browse/0"). Is this a bug, or are there some configuration settings I have missed?

Re: browse/0 = browse/1

PostPosted: Sat Dec 17, 2011 3:13 pm
by Harm10
I suspect this to be a bug, reading your description. Maybe hansfn can confirm this?
BTW are you using MySQL or flat file? And of course: you are running 2.3.1?

Re: browse/0 = browse/1

PostPosted: Sat Dec 17, 2011 3:40 pm
by ktbre
I'm running 2.3.1 and flat files.

Re: browse/0 = browse/1

PostPosted: Mon Dec 19, 2011 11:52 pm
by hansfn
I can't reproduce this myself, but it might be some kind of edge case. Only published entries are considered, but something is definitely wrong on your site. Could I get access to your PivotX - send a message to hansfn@pivotx.net Debugging this through the forum could take ages.

Re: browse/0 = browse/1

PostPosted: Mon Jan 02, 2012 7:06 pm
by hansfn
This bug was just fixed in revision 4036 (which will be included in PivotX 2.3.2). Thx for the bug report ...