wrong entrypage

Get help with installation and running PivotX 2.0.x here. Please do not post Extension or Theme related questions here.

wrong entrypage

Postby DaZ » Thu Dec 06, 2007 8:35 am

Help needed on this. When i click the entry title, to view the article on a the main pag, Pivot fails to open the correct item.
The only item that opens is a test article. By example; when i click the entry http://purmerend.dezekerweter.com/x2/?e=12 pivot open only this article http://purmerend.dezekerweter.com/x2/?e=2. It looks like Pivot has his own favorite page :) .
When i click on the archieve links (shown in the bottom) i only get an empty page. "Help" is the right word to mention at this moment... :D
DaZ
 

Re: wrong entrypage

Postby hansfn » Thu Dec 06, 2007 9:34 am

Yes, it really looks as Pivot has his own favorite page.
1) What kind of database - MySL or flatfile?
2) Have you any kind of URL rewrite enabled (in .htaccess)?
3) Please turn on debugging.
hansfn
Developer
 
Posts: 3280
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: wrong entrypage

Postby DaZ » Thu Dec 06, 2007 10:11 am

hansfn wrote:Yes, it really looks as Pivot has his own favorite page.
1) What kind of database - MySL or flatfile?
2) Have you any kind of URL rewrite enabled (in .htaccess)?
3) Please turn on debugging.



1) Whe are running on a MySQL dbase
2) .htaccess file is empty
3) debugging is on (and the log doesn`t show any errors (for now :D ))
DaZ
 

Re: wrong entrypage

Postby Bob » Thu Dec 06, 2007 7:07 pm

if you look at the 'previous' and 'next' entries, you see that they do show the links to the entries you'd expect..

Could you post the entire entrypage template here? My guess is that in your template the 'linkdump' weblog comes _before_ the [[ title ]] tag, correct? If so, i know what's wrong.
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: wrong entrypage

Postby DaZ » Fri Dec 07, 2007 7:02 am

Bob wrote:if you look at the 'previous' and 'next' entries, you see that they do show the links to the entries you'd expect..

Could you post the entire entrypage template here? My guess is that in your template the 'linkdump' weblog comes _before_ the [[ title ]] tag, correct? If so, i know what's wrong.

here`s the entrypage template:

Code: Select all
[[ include file="default/_sub_header.html" ]]

<div id="linkdump2">

   <h3>Snelle feitjes</h3>

    [[ widgets ]]

            <!-- begin of weblog 'linkdump' -->
            [[ subweblog name="linkdump" ]][[ literal ]]
           

    <!-- entry '[[title]]' -->
    <div class="linkdumpentry">
        <span class="title">
            &raquo; <a href="[[entrylink]]">[[title]]</a>
        </span> <br />
       
                    [[introduction]]
               
                    [[more]]
                   
                    &nbsp;
               
                    <span class="linkdumpcomments">
                        [[commentlink]] |
                  [[user field=emailtonick ]]
                        [[ editlink text="| Edit" ]]
                    </span>
           
                </div><br />
           
                       
            [[ /literal ]][[ /subweblog ]]
            <!-- end of weblog 'linkdump' -->
</div>

<div id="entries2">

    <div class="entry">

        <p class="entrynavigation">
            [[previousentry text="&laquo; <a href='%link%'>%title%</a>" cutoff=20 ]] |
            <a href="[[home]]">Home</a> |
            [[nextentry text="<a href='%link%'>%title%</a> &raquo;" cutoff=20 ]]
        </p>   

        <h2>
            <a href="[[entrylink]]">[[title]]</a>
        </h2>

        <h3>[[subtitle]]</h3>

        <span class="date">
            [[ date format="%dayname% %day% %monthname% %year% at %hour12%&#58;%minute% %ampm%." ]]
            [[ tags ]]
            [[ editlink name=" - Edit" ]]
        </span>


        [[ introduction ]]

        [[ body ]]


        <p class="comments">[[ commcount ]]</p>
       
        <div class="commentblock">       
           
            [[ comments ]]
            %anchor%
            <img src="%gravatar%" align="left" style="margin-top: 14px;" width="64" height="64" />
            <div class="comment">
                %comment%
                <cite><strong>%name%</strong> %email% %url% - %date% %editlink%</cite>
            </div>
            <br />
            [[ /comments ]]
       
        </div>


        <!-- div class="trackbackblock"> 
                [-[trackbacks]]               
                [-[tracklink]]
        </div -->

        <br />
        [[message]]
        <br />

        [[commentform]]

    </div>
</div>

<div style="clear:both">
    &nbsp;
</div>
</div>

[[ include file="default/_sub_footer.html" ]]
DaZ
 

Re: wrong entrypage

Postby Bob » Fri Dec 07, 2007 7:22 am

Like i suspected! It's on the bugtracker, and i'll fix it! :-)
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: wrong entrypage

Postby DaZ » Fri Dec 07, 2007 7:35 am

Bob wrote:Like i suspected! It's on the bugtracker, and i'll fix it! :-)


great Thanks!
DaZ
 

Re: wrong entrypage

Postby DaZ » Fri Dec 07, 2007 7:45 am

I also mentioned that the archieve links are showing an empty page when activated, should i make a new subject or can i add it in this one?
DaZ
 

Re: wrong entrypage

Postby Bob » Fri Dec 07, 2007 7:56 am

That's already reported, so it's on the list as well. :-)
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm


Return to 2.x Support Forum

Who is online

Users browsing this forum: No registered users and 9 guests

cron