Page 1 of 1

Can not rebuild indexes, Forced logoff

PostPosted: Fri Apr 01, 2016 1:02 am
by jeboyd
I have just moved my Pivotx from islandfreepress.org/PivotBlog (IFP) to hatterasdesigns.net/PivotBlog (HD) and now have the blog running on both sites.
However, on the new HD site I had a few issues. Tried all of this in multiple browsers, cleared browser cache as well as the Pivot cache in the admin.

1- I was unable to rebuild any of the 3 indexes in the admin interface. The admin displayed a box with "Error Rebuilding Index". I was, luckily, able to use your repair_db scripts1-4 to get the transferred db straightened out but couldn't rebuild using the admin even after running the repair scripts.
2- On the admin dashboard, the "Pivotx News" box just showed a moving progress bar and never completeed loading the news site. Also, the "Latest Forum Posts" did not show any content.
3- When trying to edit my theme files, the edit box opened and a moving progress bar showed but never went away and the editor never loaded. Fortunately I was able to edit my theme using ftp access.
4- When I tried to set Debug mode I got "The configuration could not be updated".

So, I was about to tell you all this and ask for help. But, I just discovered the problem and am writing anyway so that this all can be shared with the forum.
I found that when I uploaded the Pivotx folders to the new domain there was an error in the upload. My server rejected the file named ajaxhelper.php saying that it contained a virus related to the domain "43things.com". I removed those lines from the file and then it uploaded fine and all the problems above corrected themselves and I was most importantly, able to rebuild all indexes.

Here is the code I removed from ajaxhelper.php to eliminate the upload error:
case "43things":
self::_getTagFeedHelper('http://www.43things.com/rss/goals/tag?name='.str_replace(" ", "+", $tag), '43things.com', $tag); break;

Finally, I do have one remaing issue that I hope you can help with. Whenever I change anything in the admin interface the system immediately logs me off and does not save the changes so I am unable to, for example delete the sample posts, set debug mode, etc. I'm sure this is something simple and would really appreciate your help. If you need login credentials to investigate just let me know how to provide them.

Thanks,
JIm


Then, I discovered from the server

The IFP and HD sites are on the same server running php 5.2.17, both use Pivotx 2.3.11. Safe mode is off.
Permissions on images, db and templates are set to 777.

Re: Can not rebuild indexes, Forced logoff

PostPosted: Sat Apr 02, 2016 8:46 am
by Harm10
A long story............... :(
I cannot comment on the 43things part as I have no real knowledge on the ajaxhelper file.

About the logging off: there are several references on the forum that this could be because your login cookie is corrupt. Most of the times actively logging out and in from the dashboard refreshes the cookie and resolves the problem. Could you try that?

Re: Can not rebuild indexes, Forced logoff

PostPosted: Sat Apr 02, 2016 1:49 pm
by jeboyd
Thank you very much for your reply. Tried clean logoff and logon from dashboard several times but no help. Tried deleting cookies but no help. Tried in several browsers but no help.
The auto-logoff only occurs when I try to do certain things. I first noticed it when I tried to delete an entry by clicking its delete icon in the listing on the dashboard. System responds with "do you really want to delete?", I click yes and I am then logged off and taken to the login screen. When I log back in the entry has not been deleted. It's as if a certain script file is corrupted or something.
A similar thing happens when I try to turn on debug mode. I check the box, click save and the system says "the configuration was saved". I then click ReturnToDashboard and I am logged off. When I log back in I find that Debug has not been turned on.
May I pm login credentials to you?

Re: Can not rebuild indexes, Forced logoff

PostPosted: Sat Apr 02, 2016 3:44 pm
by Harm10
Did you try to compare all files to the files in the installation file?

I am willing to have a short look so you can send me some log in credentials.

Re: Can not rebuild indexes, Forced logoff

PostPosted: Sat Apr 02, 2016 4:46 pm
by jeboyd
Thank you very much Harm10.
I will do the file compare next.
PMing credentials to you now.
Jim

Re: Can not rebuild indexes, Forced logoff

PostPosted: Sat Apr 02, 2016 8:23 pm
by Harm10
OK, I looked around for a short while like I promised......
I compared the files and I am wondering where you got PivotX version from? It is a 2.3.11 version but several files on your site are different from the original files.
In the templates_internal folder and editor_wysi there are differences. How come?
I reinstated the ajaxhelper.php (with the same change you made for the 42things bit) because the version that was there now was rather old and very incomplete.
Alas it did not help.
Then I checked your folder rights. Did you set them according to the installation instructions? Apparently not because a lot of files in those folders were not 777.
It is described on http://book.pivotx.net/page/1-2
So I changed that too but also to no avail. Every change you make to the config seems to be OK but when you change to another section of the dashboard you get logged out.
I managed to switch debug on by editing the config file and upload that.
Most of the times when I even want to look into the debug log I get logged out there too.
I once saw a CSRF error and an error that user should be logged out because no one was logged in.

So I advice you to resolve all other differences that are non-intentional. This will probably not help but you'll never know.
Be sure to clear cache and the likings.

If problems persist try to PM hansfn and see whether he is willing to debug your problem.
Please remember that development and functional support of PivotX has long been stopped and really only the bare necessities are still debugged.

Sorry I couldn't be of more help............ :?

Re: Can not rebuild indexes, Forced logoff

PostPosted: Sat Apr 02, 2016 8:37 pm
by jeboyd
Harm10,
Ok. Thanks for your efforts. I will try a few more things and then maybe ask Hans for some advice if I can't get it working better.
I copied the files from a well-functioning site on another domain and it may be a little outdated but it is 2.3.11 and it's still working well on the other domain.
I do think that there were some errors during upload so I am still combing through the files looking for corruption.

And, I do realize that Pivotx is at end-of-life so help is very limited and you have been very kind!
Thanks again,
Jim