Can't login: users-table missing?

Get help with installation and running PivotX 2.0.x here. Please do not post Extension or Theme related questions here.

Can't login: users-table missing?

Postby Simon » Mon Nov 26, 2007 1:24 pm

I've been trying to install Pivot this morning, and although it creates the database tables and says it has created a new user, I can't login (Incorrect username/password). When inspecting the database structure I noticed there is no "pivot_users" table (or something like that). I have 7 tables: _categories, _chapters, _comments, _entries, _pages, _tags, _trackbacks. What's wrong?
Simon
 
Posts: 4
Joined: Mon Nov 26, 2007 11:05 am

Re: Can't login: users-table missing?

Postby Bob » Mon Nov 26, 2007 1:29 pm

The users are stored in a file in pivot/db/, not in the database (yet).

Make sure you use the CorRect cAsE for username and login.

If you'd like to start over, just empty the pivot/db/ folder, and go back to pivot/index.php to make a new user.. However, be sure that you've absolutely deleted your cookies before making a new user!
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: Can't login: users-table missing?

Postby Simon » Mon Nov 26, 2007 2:32 pm

I'm 100% sure I entered my username/password correctly. However, I discovered what the problem is. Apparently Pivot can't handle uppercase characters in usernames. I created a new account with username "Simon" and I was unable to login (I've retried this a couple of times now). When I entered 'simon' as username it works and I can login without any problems. If capitals aren't allowed in usernames Pivot should prohibit me from creating a username with one in it.

Thanks for your help, I'm in and I'm going to take a look at it now.
Simon
 
Posts: 4
Joined: Mon Nov 26, 2007 11:05 am

Re: Can't login: users-table missing?

Postby Bob » Mon Nov 26, 2007 2:37 pm

Thanks for narrowing it down! :-)

Added to the bug-tracker, and we'll fix it for the next release.
Bob
Lead Developer
 
Posts: 1374
Joined: Tue Nov 20, 2007 11:16 pm

Re: Can't login: users-table missing?

Postby Simon » Mon Nov 26, 2007 2:43 pm

No problem. Did some more testing (you probably know this already). When I create a username "Simon", I can't login with "Simon", but I can login with "simon". The login form says nicely that a username may only contain a-z characters, this info is missing on the first set-up page.

Looking forward to new releases.
Simon
 
Posts: 4
Joined: Mon Nov 26, 2007 11:05 am

Re: Can't login: users-table missing?

Postby BrotherHead » Thu Nov 29, 2007 3:57 am

Thanks for this info.

I was having the same problem until I did my username in all lower case.

Thanks.

Aaron Moss
BrotherHead
 
Posts: 2
Joined: Thu Nov 29, 2007 3:54 am


Return to 2.x Support Forum

Who is online

Users browsing this forum: Majestic-12 [Bot] and 2 guests

cron