Contact form not working anymore after upgrade RC1 -SOLVED-

Get help with installation and running PivotX 2.0.x here. Please do not post Extension or Theme related questions here.

Contact form not working anymore after upgrade RC1 -SOLVED-

Postby dwaas » Wed Mar 11, 2009 9:57 pm

Hi folks,

upgrading worked fine (from version D I think)...
It's just that my contact-form doesn't work anymore.
I installed using these instructions ( viewtopic.php?f=9&t=451&p=2806&hilit=contact+form#p2247 ) from Bob and it always worked fine.

Could it have something to do with this line: "[[ php ]]chdir("../gbcf-v3/");include_once("form.php");[[ /php ]]" ? I think I read somewhere that PHP-inclusion was restricted or something. If so... how do I fix this?

regards
Last edited by dwaas on Wed Mar 11, 2009 10:18 pm, edited 1 time in total.
User avatar
dwaas
Contributor
 
Posts: 93
Joined: Mon May 19, 2008 9:11 am
Location: Maastricht, The Netherlands

Re: Contact form not working anymore after upgrade to RC1

Postby ptr » Wed Mar 11, 2009 10:12 pm

I think it has something to do with the new php restrictions. Please add the rule "allow_php_in_templates" to the advanced configuration settings and set the value to "1".

http://book.pivotx.net/index.php?page=app-a says:

allow_php_in_templates - If set to '1', you will be albe to use [[php]] tags inside your templates. Do not use this, unless you're certain that no ill-willing people have access to the templates.
ptr
PivotX Team
 
Posts: 78
Joined: Sun Dec 16, 2007 2:53 pm

Re: Contact form not working anymore after upgrade to RC1

Postby dwaas » Wed Mar 11, 2009 10:17 pm

Heeeeey GREAT!

That did the job, thanks PTR! :D
User avatar
dwaas
Contributor
 
Posts: 93
Joined: Mon May 19, 2008 9:11 am
Location: Maastricht, The Netherlands


Return to 2.x Support Forum

Who is online

Users browsing this forum: No registered users and 3 guests

cron