Page 1 of 1

which PHP version PivotX2.2.2 need?

PostPosted: Fri Jan 14, 2011 1:51 am
by smithfox
I still can run PivotX2.12 in PHP4.3, but it seem that PivotX2.2.x does not support PHP4.x!

is it a special change in PivotX2.2?

Re: which PHP version PivotX2.2.2 need?

PostPosted: Fri Jan 14, 2011 6:53 am
by Harm10
PHP4 is rather old........................ you should do or ask for an upgrade! :(
But I think PivotX only warns you at the moment that features could possibly not work!
Anyway try to get an upgrade!

Re: which PHP version PivotX2.2.2 need?

PostPosted: Fri Jan 14, 2011 9:45 am
by hansfn
I wouldn't expect PivotX 2.2, and newer, to work on PHP 4 - the official requirement is 5.2.0. PHP 4 is ancient.

Re: which PHP version PivotX2.2.2 need?

PostPosted: Fri Jan 14, 2011 1:05 pm
by ilvalle
hansfn wrote:the official requirement is 5.2.0. PHP 4 is ancient.


is there any special reason regarding this particular version? For instance features not present in the previous versions? btw which are?
I am using pivotx 2.2 with php 5.1.6 and it seems quite stable and workable.

Re: which PHP version PivotX2.2.2 need?

PostPosted: Fri Jan 14, 2011 1:18 pm
by hansfn
5.1.6 is known to be buggy and is from August 2006, yes that old, but it might work most of the time. By the way, we are not the only one requiring 5.2 - Drupal is doing it too. The stable release of PHP is now 5.2.x and 5.3.x - 5.1.x isn't supported anymore.