Rewrite problem

Discuss PivotX 2.0.x here. Non-PivotX related discussions go in The Drain.

Rewrite problem

Postby mruwa1z » Sat May 25, 2013 12:18 pm

Hi! I wanted to use mod_rewrite on my page and i can't see any problem with it except one - Nivo slider doesn't want to work.
It's just like here viewtopic.php?f=9&t=3370&start=10 and yes, i'm pointing to Minify topic to show you that it is similar problem.
When the Minify was ON Nivo slider doesn't wanted to work but it's ok now after the Minify file change. I've got the same problem with mod_rewrite.
Last edited by mruwa1z on Sat Aug 10, 2013 2:40 pm, edited 1 time in total.
If i'm asking for help, it's about this site - http://klinrap.com
mruwa1z
 
Posts: 24
Joined: Sat May 04, 2013 3:37 pm

Re: Rewrite problem

Postby Harm10 » Sat May 25, 2013 10:46 pm

What settings did you use for Minify? Backend only? Frontend only?
Did you install the fix Hans points to in the forumpost you are mentioning?

To be absolutely sure it doesn't work use weblog Skinny to check it out (has the least other functions installed).

Also take note of the remark by Hans that minify sometimes just doesn't work on specific servers......
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Rewrite problem

Postby hansfn » Sun May 26, 2013 5:04 am

What exactly doesn't work in Nivo slider when you enable mod_rewrite? Give a link to a page with the problem (and explain what doesn't work).
hansfn
Developer
 
Posts: 3281
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Rewrite problem

Postby mruwa1z » Sun May 26, 2013 12:28 pm

Well, Harm... Minify works fine and i can't see any problem with it. It's just an example that i've got a similar problem with mod_rewrite.
When it's enabled - slider doesn't want to work, what's funny? It works on my homepage but when i'm in the entry/category view it's messed up.

EDIT:
mod_rewrite works fine only on my homepage http://klinrap.com (Start page is the default one) but when it's klinrap.com/page/start well whatever page/category/entry view, Nivo slider doesn't want to work.

EDIT2:
I HAVE FIXED THE PROBLEM. It was about image links attached to the slider-wraper div. Without mod_rewrite for example
Code: Select all
<img src='slider/img/ta_noc.jpg' width="530" height="120"  title="#ta_noc">
But when you use mod_rewrite it has to be like this
Code: Select all
<img src='/slider/img/ta_noc.jpg' width="530" height="120"  title="#ta_noc">
It's all about the "/" char.
Attachments
slider.jpg
to the right
slider.jpg (545.08 KiB) Viewed 4730 times
If i'm asking for help, it's about this site - http://klinrap.com
mruwa1z
 
Posts: 24
Joined: Sat May 04, 2013 3:37 pm


Return to 2.x Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron