Bonus Forms

Discuss PivotX 2.0.x extensions here, and view extensions that are available for download.

Re: Bonus Forms

Postby Sanzine » Mon Jul 11, 2011 10:05 am

I just installed the extension Bonus Forms and it works perfectely. I used the Dutch contactform and added a lot of extra fields.

However, I can't find the option to add or remove validation. When editing a field there is nothing beneath [ validation ]. So no input option, no text, nothing.

What am I doing wrong?
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby marcelfw » Mon Jul 11, 2011 3:35 pm

Is there also nothing beneath the [ validation ] for the standard fields? Validations are mostly non-type ('Type') specific, they are all the same for every type, so every field should always show them all.
My best guess at the moment is that there is a problem with loading of the extension.

A few questions that might help me:
- which field types don't work (next to the 'Type' item)
- which PivotX, which Bonusfields and which PHP version do you have?
- do you have PivotX debug/logging enabled and does it show any (relevant) messages?

One thing you might try:
It isn't necessary to change any code in the extension itself (not even the templates), but perhaps something got somehow changed. You could try re-installing the extension. Just remove it completely and install it again.
marcelfw
 
Posts: 44
Joined: Wed Nov 10, 2010 3:40 pm

Re: Bonus Forms

Postby Sanzine » Mon Jul 11, 2011 7:50 pm

I already typed a long reply when I checked the files in the extension folder... And there it was... the bonusforms_validations.php was 0, so it propably wasn't uploaded correctly. I uploaded the file again and it's all working now!

Thanks for your help anyhow!
Sanzine
 
Posts: 75
Joined: Tue Jan 20, 2009 10:15 am

Re: Bonus Forms

Postby marcelfw » Tue Jul 12, 2011 7:16 am

No problem.

Cheers.
marcelfw
 
Posts: 44
Joined: Wed Nov 10, 2010 3:40 pm

Re: Bonus Forms

Postby habbekak » Fri Sep 23, 2011 7:29 pm

Hello,
The 'save' button doesn't work with PivotX 3.0.
I work with Firefox and Chrome.
Maybe you can fix it :D
Follow me on twitter, so you can check my time line.....
www.twitter.com/habbekak
habbekak
 
Posts: 46
Joined: Sun Jan 24, 2010 10:56 am
Location: Petten (NL, North-Holland)

Re: Bonus Forms

Postby Harm10 » Fri Sep 23, 2011 8:03 pm

habbekak wrote:Maybe you can fix it :D
I think marcelfw is still on vacation until end of September.
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Bonus Forms

Postby hansfn » Fri Sep 23, 2011 8:36 pm

I'm wondering if this is the same problem as in the Unable to save changes configuration page forum thread. Just a wild guess.
hansfn
Developer
 
Posts: 3282
Joined: Sun Nov 25, 2007 7:48 pm
Location: Molde, Norway

Re: Bonus Forms

Postby Harm10 » Sat Sep 24, 2011 3:38 pm

Just upgraded to 2.3.0. Got the same problem. Save button is not clickable (in FF). In IE9 I have a script error (below). When I continue I can click the save button. The same script error is shown followed by the second (below). After that you can click what you like but nothing happens.
edit: In Chrome 14 the same thing as FF.

Code: Select all
Regel: 16
Karakter: 15483
Foutnummer: 0
Error: bonusforms_init_form is niet gedefinieerd

Translation: bonusforms_init_form is not defined
Code: Select all
Regel: 16
Karakter: 12160
Foutnummer: 0
Error: Kan deze bewerking niet voltooien door fout 80020101.

Translation: Cannot complete this action because of error 80020101.

Annoying............... :cry:
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

Re: Bonus Forms

Postby marcelfw » Mon Sep 26, 2011 7:39 am

Most likely this is caused by a never_jquery is 1. Can you check this? At this time, the javascript never gets included in never_jquery is set. The basic bonusforms is not dependent on jQuery for proper functioning but the preset code is build using jQuery code.

I should either disable the preset code when jQuery is not set or rewrite it so it works without jQuery. Problem is that although we regulary set never_jquery to 1 we still include jQuery ourselves in the html so the bonusforms still works usually.
marcelfw
 
Posts: 44
Joined: Wed Nov 10, 2010 3:40 pm

Re: Bonus Forms

Postby Harm10 » Mon Sep 26, 2011 10:34 am

Hi! What should I look at to confirm whether never_jquery is 1?
I can see the jquery includes just below the title tag
Code: Select all
<!-- jquery and the likes -->
<script src="/sitetest/pivotx/includes/js/jquery-1.6.2.min.js" type="text/javascript"></script>
<script src="includes/js/jquery-ui-1.8.15.custom.min.js" type="text/javascript"></script>
<script src="includes/js/jquery-plugins.js" type="text/javascript"></script>
Quality is in the detail of things............

Want to change or update your PivotX site? Mail or PM me!
I can also convert your site to a Wordpress site!
Harm10
Developer
 
Posts: 2011
Joined: Wed Jun 17, 2009 9:37 am
Location: Somewhere in The Netherlands (aka Holland)

PreviousNext

Return to 2.x Extensions

Who is online

Users browsing this forum: No registered users and 2 guests

cron